WordPress 代码高亮插件 SyntaxHighlighter Evolved (古腾堡支持)

不管是普通的 WordPress 用户还是专业的开发者,许多人都喜欢将自己的用过代码记录在博客中,但是众所周知 WordPress 自身的代码功能非常简陋的,甚至没有高亮效果,难以阅读,如果你想要展示漂亮的代码效果,必须安装一款合适的代码高亮插件。注意 WordPress 更换新版古腾堡编辑器。

SyntaxHighlighter Evolved

SyntaxHighlighter Evolved 是一款非常简洁的插件,最大的特点就是使用方便,他不会为编辑器添加任何多余的元素,如果你想高亮代码,只需要在代码的前后插入对应语言的短代码即可。

下载地址:
https://wordpress.org/plugins/syntaxhighlighter/

安装以后,可以看到说明:

使用方法:

1、在新的 Block 中,选择的是:代码

2、将代码拷贝进去

3、转换,选择:SyntaxHighlighter Code

4、在右侧会出现 SyntaxHighlighter Code 的设置项,选择对应的语言。

5、在预览页面的效果

就是这样的效果

发表评论

邮箱地址不会被公开。 必填项已用*标注